<!doctype html >
<!--[if lt IE 7]> <html class="no-js ie6 oldie" lang="en"> <![endif]-->
<!--[if IE 7]>    <html class="no-js ie7 oldie" lang="en"> <![endif]-->
<!--[if IE 8]>    <html class="no-js ie8 oldie" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="no-js ie9 oldie" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en-US" prefix="og: http://ogp.me/ns#"> <!--<![endif]-->
<head>
<title>Texas Priest Miraculously Survives Attempted Shooting, Suspects’ Gun Fails to Fire Three Times | ChurchPOP</title>
<meta charset="UTF-8" />
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.8.1/jquery.min.js"></script>
<script async src="https://cdn.onthe.io/io.js/KyPNEFRM5FBK"></script>
<script>
window._io_config = window._io_config || {};
window._io_config["0.2.0"] = window._io_config["0.2.0"] || [];
window._io_config["0.2.0"].push({
    page_url: "https://churchpop.com/2019/09/14/houston-priest-beaten-after-gun-fails-to-fire-says-divine-intervention-saved-his-life-i-should-be-dead/",
    page_title: "Texas Priest Miraculously Survives Attempted Shooting, Suspects’ Gun Fails to Fire Three Times",
    page_type: "article",
    page_language: "en",
    article_authors: ["ChurchPOP Editor"],
    article_categories: ["Articles", "Featured", "News"],
    article_word_count: "301",
    article_publication_date: "Sat, 14 Sep 2019 14:42:22 +0000"
});
</script>
<script type="text/javascript">
    (function() {
        function async_load(script_url){
            var protocol = ('https:' == document.location.protocol ? 'https://' : 'http://');
            var s = document.createElement('script'); s.src = protocol + script_url;
            var x = document.getElementsByTagName('script')[0]; x.parentNode.insertBefore(s, x);
        }
        bm_website_code = 'A8D0AB71C4114A3E';
        jQuery(document).ready(function(){async_load('asset.pagefair.com/measure.min.js')});
        jQuery(document).ready(function(){async_load('asset.pagefair.net/ads.min.js')});
    })();
</script>
<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>
<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.defineSlot('/1319756/CPOP_Sidebar_A', [[300, 250], [300, 169], 'fluid'], 'div-gpt-ad-1428502564272-0').addService(googletag.pubads()).setCollapseEmptyDiv(true,true);
googletag.defineSlot('/1319756/CPOP_Sidebar_B', [[300, 250], [300, 169], 'fluid'], 'div-gpt-ad-1428502564272-1').addService(googletag.pubads()).setCollapseEmptyDiv(true,true);
googletag.defineSlot('/1319756/CPOP_Sidebar_C', [300, 250], 'div-gpt-ad-1428502564272-2').addService(googletag.pubads());
googletag.defineSlot('/1319756/CPOP_Article_1', [300, 250], 'div-gpt-ad-1441211653400-0').addService(googletag.pubads()).setCollapseEmptyDiv(true,true);
googletag.defineSlot('/1319756/CPOP_EN_ArticleTop', [300, 250], 'div-gpt-ad-1493839612370-0').addService(googletag.pubads()).setCollapseEmptyDiv(true,true);
googletag.pubads().enableSingleRequest();
googletag.pubads().collapseEmptyDivs();
googletag.enableServices();
});
</script>

<meta name="author" content="ChurchPOP Editor">
<link rel="pingback" href="https://churchpop.com/xmlrpc.php" />
<meta property="og:image" content="https://churchpop.com/wp-content/uploads/2019/09/Priest-rosary2.jpg" /><link rel="icon" type="image/png" href="https://churchpop.com/wp-content/uploads/2016/08/16.png"><link rel="apple-touch-icon-precomposed" sizes="76x76" href="https://churchpop.com/wp-content/uploads/2016/08/76.png" /><link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://churchpop.com/wp-content/uploads/2016/08/120.png" /><link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://churchpop.com/wp-content/uploads/2016/08/152.png" /><link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://churchpop.com/wp-content/uploads/2016/08/114.png" /><link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://churchpop.com/wp-content/uploads/2016/08/144.png" /><script type='text/javascript'>function ctSetCookie(c_name, value, def_value){document.cookie = c_name + '=' + escape(value) + '; path=/';}ctSetCookie('ct_checkjs', '369045114', '0');</script>

<script data-cfasync="false" type="text/javascript">//<![CDATA[
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
//]]>
</script>


<link rel="canonical" href="https://churchpop.com/2019/09/14/houston-priest-beaten-after-gun-fails-to-fire-says-divine-intervention-saved-his-life-i-should-be-dead/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Texas Priest Miraculously Survives Attempted Shooting, Suspects’ Gun Fails to Fire Three Times | ChurchPOP" />
<meta property="og:description" content="What a miracle! 😱 Praise God for saving this priest&#039;s life! 🙌" />
<meta property="og:url" content="https://churchpop.com/2019/09/14/houston-priest-beaten-after-gun-fails-to-fire-says-divine-intervention-saved-his-life-i-should-be-dead/" />
<meta property="og:site_name" content="ChurchPOP" />
<meta property="article:publisher" content="https://www.facebook.com/churchpopsite" />
<meta property="article:author" content="https://www.facebook.com/churchpopsite" />
<meta property="article:tag" content="bible" />
<meta property="article:tag" content="Catholic" />
<meta property="article:tag" content="catholic church" />
<meta property="article:tag" content="catholic priests" />
<meta property="article:tag" content="catholicism" />
<meta property="article:tag" content="catholics" />
<meta property="article:tag" content="christ" />
<meta property="article:tag" content="christian" />
<meta property="article:tag" content="christianity" />
<meta property="article:tag" content="christians" />
<meta property="article:tag" content="church" />
<meta property="article:tag" content="churches" />
<meta property="article:tag" content="crime" />
<meta property="article:tag" content="crime stories" />
<meta property="article:tag" content="criminal" />
<meta property="article:tag" content="faith" />
<meta property="article:tag" content="god" />
<meta property="article:tag" content="gospel" />
<meta property="article:tag" content="history" />
<meta property="article:tag" content="houston" />
<meta property="article:tag" content="houston police department" />
<meta property="article:tag" content="houston texas" />
<meta property="article:tag" content="houston tx" />
<meta property="article:tag" content="jesus" />
<meta property="article:tag" content="jesus christ" />
<meta property="article:tag" content="life saving" />
<meta property="article:tag" content="love" />
<meta property="article:tag" content="mass" />
<meta property="article:tag" content="miracle" />
<meta property="article:tag" content="police officer" />
<meta property="article:tag" content="pray" />
<meta property="article:tag" content="prayer" />
<meta property="article:tag" content="priest" />
<meta property="article:tag" content="priest assaulted" />
<meta property="article:tag" content="priest attacked" />
<meta property="article:tag" content="priest life" />
<meta property="article:tag" content="priest saved" />
<meta property="article:tag" content="priests" />
<meta property="article:tag" content="pro-life" />
<meta property="article:tag" content="prolife" />
<meta property="article:tag" content="saint" />
<meta property="article:tag" content="saints" />
<meta property="article:tag" content="scripture" />
<meta property="article:tag" content="supernatural" />
<meta property="article:tag" content="suspect" />
<meta property="article:tag" content="suspect taken into custody" />
<meta property="article:tag" content="texas" />
<meta property="article:tag" content="video" />
<meta property="article:tag" content="videos" />
<meta property="article:section" content="Articles" />
<meta property="article:published_time" content="2019-09-14T21:42:22+00:00" />
<meta property="article:modified_time" content="2019-09-14T22:36:49+00:00" />
<meta property="og:updated_time" content="2019-09-14T22:36:49+00:00" />
<meta property="og:image" content="https://churchpop.com/wp-content/uploads/2019/09/Priest-rosary2.jpg" />
<meta property="og:image:secure_url" content="https://churchpop.com/wp-content/uploads/2019/09/Priest-rosary2.jpg" />
<meta property="og:image:width" content="800" />
<meta property="og:image:height" content="500" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="What a miracle! 😱 Praise God for saving this priest&#039;s life! 🙌" />
<meta name="twitter:title" content="Texas Priest Miraculously Survives Attempted Shooting, Suspects’ Gun Fails to Fire Three Times | ChurchPOP" />
<meta name="twitter:site" content="@church_pop" />
<meta name="twitter:image" content="http://churchpop.com/wp-content/uploads/2019/09/Priest-rosary2.jpg" />
<meta name="twitter:creator" content="@Church_POP" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://churchpop.com/#website","url":"https://churchpop.com/","name":"ChurchPOP","publisher":{"@id":"https://churchpop.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://churchpop.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https://churchpop.com/2019/09/14/houston-priest-beaten-after-gun-fails-to-fire-says-divine-intervention-saved-his-life-i-should-be-dead/#webpage","url":"https://churchpop.com/2019/09/14/houston-priest-beaten-after-gun-fails-to-fire-says-divine-intervention-saved-his-life-i-should-be-dead/","inLanguage":"en-US","name":"Texas Priest Miraculously Survives Attempted Shooting, Suspects\u2019 Gun Fails to Fire Three Times | ChurchPOP","isPartOf":{"@id":"https://churchpop.com/#website"},"image":{"@type":"ImageObject","@id":"https://churchpop.com/2019/09/14/houston-priest-beaten-after-gun-fails-to-fire-says-divine-intervention-saved-his-life-i-should-be-dead/#primaryimage","url":"https://churchpop.com/wp-content/uploads/2019/09/Priest-rosary2-100x65.jpg","caption":"<a href=https://twitter.com/JeffEhlingABC13/status/1172498509150527493\">@JeffEhlingABC13, Twitter</a> / ChurchPOP"},"primaryImageOfPage":{"@id":"https://churchpop.com/2019/09/14/houston-priest-beaten-after-gun-fails-to-fire-says-divine-intervention-saved-his-life-i-should-be-dead/#primaryimage"},"datePublished":"2019-09-14T21:42:22+00:00","dateModified":"2019-09-14T22:36:49+00:00"},{"@type":"Article","@id":"https://churchpop.com/2019/09/14/houston-priest-beaten-after-gun-fails-to-fire-says-divine-intervention-saved-his-life-i-should-be-dead/#article","isPartOf":{"@id":"https://churchpop.com/2019/09/14/houston-priest-beaten-after-gun-fails-to-fire-says-divine-intervention-saved-his-life-i-should-be-dead/#webpage"},"author":{"@id":"https://churchpop.com/author/editor/#author","name":"ChurchPOP Editor"},"publisher":{"@id":"https://churchpop.com/#organization"},"headline":"Texas Priest Miraculously Survives Attempted Shooting, Suspects\u2019 Gun Fails to Fire Three Times","datePublished":"2019-09-14T21:42:22+00:00","dateModified":"2019-09-14T22:36:49+00:00","commentCount":0,"mainEntityOfPage":"https://churchpop.com/2019/09/14/houston-priest-beaten-after-gun-fails-to-fire-says-divine-intervention-saved-his-life-i-should-be-dead/#webpage","image":{"@id":"https://churchpop.com/2019/09/14/houston-priest-beaten-after-gun-fails-to-fire-says-divine-intervention-saved-his-life-i-should-be-dead/#primaryimage"},"keywords":"bible,Catholic,catholic church,catholic priests,catholicism,catholics,christ,christian,christianity,christians,church,churches,crime,crime stories,criminal,faith,god,gospel,history,houston,houston police department,houston texas,houston tx,jesus,jesus christ,life saving,love,mass,miracle,police officer,pray,prayer,priest,priest assaulted,priest attacked,priest life,priest saved,priests,pro-life,prolife,saint,saints,scripture,supernatural,suspect,suspect taken into custody,texas,video,videos","articleSection":"Articles,Featured,News"},{"@type":"Person","@id":"https://churchpop.com/author/editor/#author","name":"ChurchPOP Editor","image":{"@type":"ImageObject","@id":"https://churchpop.com/#personlogo","url":"https://churchpop.com/wp-content/uploads/2017/04/circle-gradiant-150x150.png","caption":"ChurchPOP Editor"},"description":"Make holy all the things!","sameAs":["https://www.facebook.com/churchpopsite","https://www.instagram.com/churchpop/","https://twitter.com/https://twitter.com/Church_POP"]}]}</script>

<link rel="amphtml" href="https://churchpop.com/2019/09/14/houston-priest-beaten-after-gun-fails-to-fire-says-divine-intervention-saved-his-life-i-should-be-dead/amp/" /><link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="ChurchPOP &raquo; Feed" href="https://churchpop.com/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/churchpop.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.11"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='contact-form-7-css' href='https://churchpop.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='sb_instagram_styles-css' href='https://churchpop.com/wp-content/plugins/instagram-feed/css/sb-instagram.min.css?ver=1.12' type='text/css' media='all' />
<link rel='stylesheet' id='sb-font-awesome-css' href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='google-font-opensans-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A300%2C400%2C600%2C700&#038;subset=latin%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese%2Clatin-ext%2Ccyrillic&#038;ver=4.9.11' type='text/css' media='all' />
<link rel='stylesheet' id='google-font-ubuntu-css' href='https://fonts.googleapis.com/css?family=Ubuntu%3A300%2C400%2C500%2C700%2C300italic%2C400italic%2C500italic%2C700italic&#038;subset=latin%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Clatin-ext%2Ccyrillic&#038;ver=4.9.11' type='text/css' media='all' />
<link rel='stylesheet' id='google-font-pt-sans-css' href='https://fonts.googleapis.com/css?family=PT+Sans%3A400%2C700%2C400italic&#038;subset=latin%2Ccyrillic-ext%2Clatin-ext%2Ccyrillic&#038;ver=4.9.11' type='text/css' media='all' />
<link rel='stylesheet' id='google-vollkorn-css' href='https://fonts.googleapis.com/css?family=Vollkorn%3A400italic%2C700italic%2C400%2C700&#038;ver=4.9.11' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css' href='https://fonts.googleapis.com/css?family=Oswald%3A400%2C700%7CRoboto%3A400%2C700&#038;ver=4.9.11' type='text/css' media='all' />
<link rel='stylesheet' id='td-bootstrap-css' href='https://churchpop.com/wp-content/themes/Newspaper/includes/wp_booster/external/bootstrap/td-bootstrap.css?ver=4.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css' href='https://churchpop.com/wp-content/themes/Newspaper/style.css?ver=4.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css' href='https://churchpop.com/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' />
<style id='addtoany-inline-css' type='text/css'>
@media screen and (max-width:1025px){
.a2a_floating_style.a2a_vertical_style{display:none;}
}
@media screen and (min-width:1025px){
.a2a_floating_style.a2a_default_style{display:none;}
}
</style>
<script type='text/javascript' src='https://churchpop.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://churchpop.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://churchpop.com/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ctPublic = {"_ajax_nonce":"4632e6ca7d","_ajax_url":"https:\/\/churchpop.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://churchpop.com/wp-content/plugins/cleantalk-spam-protect/js/apbct-public.js?ver=5.117.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ctNocache = {"ajaxurl":"https:\/\/churchpop.com\/wp-admin\/admin-ajax.php","info_flag":"","set_cookies_flag":"","blog_home":"https:\/\/churchpop.com\/"};
/* ]]> */
</script>
<script type='text/javascript' src='https://churchpop.com/wp-content/plugins/cleantalk-spam-protect/inc/cleantalk_nocache.js?ver=5.117.1'></script>
<script type='text/javascript' src='https://churchpop.com/wp-content/plugins/duracelltomi-google-tag-manager/js/gtm4wp-contact-form-7-tracker.js?ver=1.9.2'></script>
<script type='text/javascript' src='https://churchpop.com/wp-content/plugins/duracelltomi-google-tag-manager/js/gtm4wp-form-move-tracker.js?ver=1.9.2'></script>
<link rel='https://api.w.org/' href='https://churchpop.com/wp-json/' />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://churchpop.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 4.9.11" />
<link rel='shortlink' href='https://churchpop.com/?p=32710' />
<link rel="alternate" type="application/json+oembed" href="https://churchpop.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fchurchpop.com%2F2019%2F09%2F14%2Fhouston-priest-beaten-after-gun-fails-to-fire-says-divine-intervention-saved-his-life-i-should-be-dead%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://churchpop.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fchurchpop.com%2F2019%2F09%2F14%2Fhouston-priest-beaten-after-gun-fails-to-fire-says-divine-intervention-saved-his-life-i-should-be-dead%2F&#038;format=xml" />
<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
a2a_config.track_links = 'googl';
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>
<meta property="fb:pages" content="541244889338367" />
<meta property="ia:markup_url" content="https://churchpop.com/2019/09/14/houston-priest-beaten-after-gun-fails-to-fire-says-divine-intervention-saved-his-life-i-should-be-dead/?ia_markup=1" />
<link rel="alternate" type="application/json" title="ChurchPOP &raquo; JSON Feed" href="https://churchpop.com/feed/json/" />

<script data-cfasync="false" type="text/javascript">//<![CDATA[
	dataLayer.push({"pagePostType":"post","pagePostType2":"single-post","pageCategory":["articles","featured","news-2"],"pageAttributes":["bible-2","catholic","catholic-church","catholic-priests","catholicism","catholics","christ","christian","christianity","christians","church","churches","crime","crime-stories","criminal","faith","god","gospel-2","history-2","houston","houston-police-department","houston-texas","houston-tx","jesus","jesus-christ","life-saving","love","mass","miracle","police-officer","pray","prayer","priest","priest-assaulted","priest-attacked","priest-life","priest-saved","priests","pro-life-2","prolife","saint","saints","scripture","supernatural-2","suspect","suspect-taken-into-custody","texas","video","videos-2"],"pagePostAuthor":"ChurchPOP Editor","instantArticle":false});//]]>
</script>
<script data-cfasync="false">//<![CDATA[
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-PZVWWRC');//]]>
</script>

<!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->

<style>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</style>

<script>
    

var td_blocks = []; //here we store all the items for the current page

//td_block class - each ajax block uses a object of this class for requests
function td_block() {
    this.id = '';
    this.block_type = 1; //block type id (1-234 etc)
    this.atts = '';
    this.td_cur_cat = '';
    this.td_column_number = '';
    this.td_current_page = 1; //
    this.post_count = 0; //from wp
    this.found_posts = 0; //from wp
    this.max_num_pages = 0; //from wp
    this.is_ajax_running = false;
}

    
var td_ad_background_click_link="";
var td_ad_background_click_target="";
var td_ajax_url="https://churchpop.com/wp-admin/admin-ajax.php";
var td_get_template_directory_uri="https://churchpop.com/wp-content/themes/Newspaper";
var tds_snap_menu="smart_snap_always";
var tds_header_style="3";
var tds_mobile_swipe="";
var td_search_url="https://churchpop.com/search/";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top="3800";
var td_responsive="";
</script>
<script type="text/javascript">
    (function() {
        function async_load(script_url){
            var protocol = ('https:' == document.location.protocol ? 'https://' : 'http://');
            var s = document.createElement('script'); s.src = protocol + script_url;
            var x = document.getElementsByTagName('script')[0]; x.parentNode.insertBefore(s, x);
        }
        bm_website_code = '49623118842440F3';
        jQuery(document).ready(function(){async_load('asset.pagefair.com/measure.min.js')});
        jQuery(document).ready(function(){async_load('asset.pagefair.net/ads.min.js')});
    })();
</script>
<style>
#popup-embedded-box-gfcr-1.popup-embedded-box-gfcr-1 {
  position : fixed;
  bottom : -281px;
  z-index : 9999999;
  left : 0px;
  display : none;
  width : 100% !important;
}

#close-mobile-offer {
  position : absolute;
  top : 5px;
  right : 10px;
  color : rgb(255, 255, 255);
  font-size : 30px;
}
</style>
<script>
$(function() {

    var $popup = $('#popup-embedded-box-gfcr-1');
    $popup.append('<div id="close-mobile-offer">&times;</div>');
    $popup.addClass('off');

    var $contentDiv = $('.td-post-text-content');

    $('#close-mobile-offer').on('click', function() {
        $popup.animate({ bottom: -281 }, function() {
            $popup.hide();
        });
    });

    var distanctToBottom = ($contentDiv.offset().top + $contentDiv.height()) - 500 ;

    $(document).scroll(function() {
        var y = $(this).scrollTop();

        if (y > distanctToBottom) {
            if ($popup.hasClass("off") && !$popup.is(':animated')) {
                $popup.show();
                $popup.animate({ bottom: 0 }, function() {
                    $popup.removeClass("off");
                });
            }
        } else {
            if (!$popup.hasClass("off") && (!$popup.is(':animated'))) {
                $popup.animate({ bottom: -40 }, function() {
                    $popup.addClass("off");
                });
            }
        }
    });

});
</script>
<script src="https://78b862e3e94243179acffa9ac56fc2a1.js.ubembed.com" async></script>
</head>
<body class="post-template-default single single-post postid-32710 single-format-standard td-full-layout td_responsive houston-priest-beaten-after-gun-fails-to-fire-says-divine-intervention-saved-his-life-i-should-be-dead">
<div id="outer-wrap">
<div id="inner-wrap">
<div id="td-mobile-nav">

<div class="td-mobile-close">
<a href="#">CLOSE</a>
<div class="td-nav-triangle"></div>
</div>
<div class="td-mobile-content">
<div class="menu-main-container"><ul id="menu-main" class=""><li id="menu-item-19" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-no-down-arrow td-not-mega menu-item-19"><a href="https://churchpop.com/"><span class="menu_icon td-sp td-sp-ico-home"></span><span class="menu_hidden">Home</span></a></li>
<li id="menu-item-207" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-not-mega menu-item-207"><a href="https://churchpop.com/category/articles/">Articles</a></li>
<li id="menu-item-20" class="menu-item menu-item-type-taxonomy menu-item-object-category td-not-mega menu-item-20"><a href="https://churchpop.com/category/lists/">Lists</a></li>
<li id="menu-item-19182" class="menu-item menu-item-type-taxonomy menu-item-object-category td-not-mega menu-item-19182"><a href="https://churchpop.com/category/video-games/">Games</a></li>
<li id="menu-item-557" class="menu-item menu-item-type-taxonomy menu-item-object-category td-not-mega menu-item-557"><a href="https://churchpop.com/category/quizzes/">Quizzes</a></li>
<li id="menu-item-12416" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-has-children td-not-mega menu-item-12416"><a href="https://churchpop.com/">More</a>
<ul class="sub-menu">
<li id="menu-item-9659" class="menu-item menu-item-type-taxonomy menu-item-object-category td-not-mega menu-item-9659"><a href="https://churchpop.com/category/comics/">Comics</a></li>
<li id="menu-item-9661" class="menu-item menu-item-type-taxonomy menu-item-object-category td-not-mega menu-item-9661"><a href="https://churchpop.com/category/infographics/">Infographics</a></li>
<li id="menu-item-156" class="menu-item menu-item-type-taxonomy menu-item-object-category td-not-mega menu-item-156"><a href="https://churchpop.com/category/videos/">Videos</a></li>
</ul>
</li>
<li id="menu-item-176" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-no-down-arrow td-not-mega menu-item-176"><a href="https://churchpop.com/about/"><span class="menu_icon td-sp td-sp-ico-categ"></span><span class="menu_hidden">Categories</span></a>
<ul class="sub-menu">
<li id="menu-item-177" class="menu-item menu-item-type-post_type menu-item-object-page td-not-mega menu-item-177"><a href="https://churchpop.com/about/">About</a></li>
<li id="menu-item-217" class="menu-item menu-item-type-post_type menu-item-object-page td-not-mega menu-item-217"><a href="https://churchpop.com/submissionstips/">Submissions/Tips</a></li>
<li id="menu-item-15921" class="menu-item menu-item-type-custom menu-item-object-custom td-not-mega menu-item-15921"><a href="http://ewtnadvertising.com/churchpop-com/">Advertising</a></li>
<li id="menu-item-178" class="menu-item menu-item-type-post_type menu-item-object-page td-not-mega menu-item-178"><a href="https://churchpop.com/contact/">Contact</a></li>
<li id="menu-item-13098" class="menu-item menu-item-type-custom menu-item-object-custom td-not-mega menu-item-13098"><a href="http://es.churchpop.com">ChurchPOP Español</a></li>
<li id="menu-item-15030" class="menu-item menu-item-type-custom menu-item-object-custom td-not-mega menu-item-15030"><a href="http://pt.churchpop.com">ChurchPOP Português</a></li>
<li id="menu-item-22709" class="menu-item menu-item-type-custom menu-item-object-custom td-not-mega menu-item-22709"><a href="http://it.churchpop.com/">ChurchPOP Italiano</a></li>
</ul>
</li>
</ul></div>
</div>
</div>

<div class="td-header-bg">
<div class="container header-style-3">
<div class="row">
 <div class="span12 td-full-logo" role="banner" itemscope="itemscope" itemtype="https://schema.org/Organization">
<div class="td-grid-wrap">
<div class="container-fluid">
<a itemprop="url" href="https://churchpop.com">
<img class="td-retina-data td-logo" data-retina="https://churchpop.com/wp-content/uploads/2017/04/en-header-right-size.png" src="https://churchpop.com/wp-content/uploads/2017/04/en-header-right-size.png" alt="" />
</a>
<meta itemprop="name" content="ChurchPOP">
</div>
</div>
</div>
</div>
</div>
</div>

<div class="td-menu-placeholder">
<div class="td-menu-background">
<div class="container td-menu-wrap">
<div class="row-fluid td-menu-header">
<div class="span10">
<div id="td-top-mobile-toggle">
<ul class="sf-menu">
<li>
<a href="#">
<span class="menu_icon td-sp td-sp-ico-menu"></span>
</a>
</li>
</ul>
</div>
<div id="td-top-menu" role="navigation" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
<div class="menu-main-container"><ul id="menu-main-1" class="sf-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-no-down-arrow td-not-mega menu-item-19"><a href="https://churchpop.com/"><span class="menu_icon td-sp td-sp-ico-home"></span><span class="menu_hidden">Home</span></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-not-mega td-mega-menu menu-item-207"><a href="https://churchpop.com/category/articles/">Articles</a>
<ul class="sub-menu">
<li id="menu-item-0" class="menu-item-0"><div class="td-mega-grid"><script>var block_td_uid_1_5d8082291f1fa = new td_block();
block_td_uid_1_5d8082291f1fa.id = "td_uid_1_5d8082291f1fa";
block_td_uid_1_5d8082291f1fa.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"75","show_child_cat":"5"}';
block_td_uid_1_5d8082291f1fa.td_cur_cat = "75";
block_td_uid_1_5d8082291f1fa.td_column_number = "1";
block_td_uid_1_5d8082291f1fa.block_type = "td_mega_menu";
block_td_uid_1_5d8082291f1fa.post_count = "5";
block_td_uid_1_5d8082291f1fa.found_posts = "1493";
block_td_uid_1_5d8082291f1fa.max_num_pages = "299";
td_blocks.push(block_td_uid_1_5d8082291f1fa);
</script><div class="td_block_wrap td_block_mega_menu td-no-subcats"><div id=td_uid_1_5d8082291f1fa class="td_block_inner">
<div class="td_mod_mega_menu">
<div class="thumb-wrap"><a href="https://churchpop.com/2019/09/16/sit-stand-or-kneel-your-how-to-guide-for-moving-at-mass-in-one-infographic/" rel="bookmark" title="Sit, Stand, or Kneel? Your How-To Guide For Moving At Mass, in One Infographic"><img width="198" height="143" itemprop="image" class="entry-thumb" src="https://churchpop.com/wp-content/uploads/2019/09/infographic-instruction-manual-mass-2-198x143.jpg" alt="" title="Sit, Stand, or Kneel? Your How-To Guide For Moving At Mass, in One Infographic" /></a></div>
<div class="item-details">
<h4 itemprop="name" class="entry-title"><a itemprop="url" href="https://churchpop.com/2019/09/16/sit-stand-or-kneel-your-how-to-guide-for-moving-at-mass-in-one-infographic/" rel="bookmark" title="Sit, Stand, or Kneel? Your How-To Guide For Moving At Mass, in One Infographic">Sit, Stand, or Kneel? Your How-To Guide For Moving At Mass, in One Infographic</a></h4>
</div>
</div>
<div class="td_mod_mega_menu">
<div class="thumb-wrap"><a href="https://churchpop.com/2019/09/15/how-can-i-be-gay-catholic-one-gay-womans-powerful-advice-to-those-with-same-sex-attraction/" rel="bookmark" title="&#8220;Can I Be Gay &#038; Catholic?&#8221;: One Woman&#8217;s Powerful Advice for Catholics With Same-Sex Attraction"><img width="198" height="143" itemprop="image" class="entry-thumb" src="https://churchpop.com/wp-content/uploads/2019/09/maxresdefault-1-198x143.jpg" alt="" title="&#8220;Can I Be Gay &#038; Catholic?&#8221;: One Woman&#8217;s Powerful Advice for Catholics With Same-Sex Attraction" /></a></div>
<div class="item-details">
<h4 itemprop="name" class="entry-title"><a itemprop="url" href="https://churchpop.com/2019/09/15/how-can-i-be-gay-catholic-one-gay-womans-powerful-advice-to-those-with-same-sex-attraction/" rel="bookmark" title="&#8220;Can I Be Gay &#038; Catholic?&#8221;: One Woman&#8217;s Powerful Advice for Catholics With Same-Sex Attraction">&#8220;Can I Be Gay &#038; Catholic?&#8221;: One Woman&#8217;s Powerful Advice for Catholics With Same-Sex Attraction</a></h4>
</div>
</div>
<div class="td_mod_mega_menu">
<div class="thumb-wrap"><a href="https://churchpop.com/2019/09/14/houston-priest-beaten-after-gun-fails-to-fire-says-divine-intervention-saved-his-life-i-should-be-dead/" rel="bookmark" title="Texas Priest Miraculously Survives Attempted Shooting, Suspects’ Gun Fails to Fire Three Times"><img width="198" height="143" itemprop="image" class="entry-thumb" src="https://churchpop.com/wp-content/uploads/2019/09/Priest-rosary2-198x143.jpg" alt="" title="Texas Priest Miraculously Survives Attempted Shooting, Suspects’ Gun Fails to Fire Three Times" /></a></div>
<div class="item-details">
<h4 itemprop="name" class="entry-title"><a itemprop="url" href="https://churchpop.com/2019/09/14/houston-priest-beaten-after-gun-fails-to-fire-says-divine-intervention-saved-his-life-i-should-be-dead/" rel="bookmark" title="Texas Priest Miraculously Survives Attempted Shooting, Suspects’ Gun Fails to Fire Three Times">Texas Priest Miraculously Survives Attempted Shooting, Suspects’ Gun Fails to Fire Three Times</a></h4>
</div>
</div>
<div class="td_mod_mega_menu">
<div class="thumb-wrap"><a href="https://churchpop.com/2019/09/13/this-married-catholic-priest-powerfully-explains-why-priests-should-be-celibate/" rel="bookmark" title="This Married Catholic Priest Powerfully Explains Why Priests SHOULD Be Celibate"><img width="198" height="143" itemprop="image" class="entry-thumb" src="https://churchpop.com/wp-content/uploads/2019/09/maxresdefault-198x143.jpg" alt="" title="This Married Catholic Priest Powerfully Explains Why Priests SHOULD Be Celibate" /></a></div>
<div class="item-details">
<h4 itemprop="name" class="entry-title"><a itemprop="url" href="https://churchpop.com/2019/09/13/this-married-catholic-priest-powerfully-explains-why-priests-should-be-celibate/" rel="bookmark" title="This Married Catholic Priest Powerfully Explains Why Priests SHOULD Be Celibate">This Married Catholic Priest Powerfully Explains Why Priests SHOULD Be Celibate</a></h4>
</div>
</div>
<div class="td_mod_mega_menu">
<div class="thumb-wrap"><a href="https://churchpop.com/2019/09/12/bedridden-woman-healed-at-knock-shrine-in-first-ever-approved-miracle-by-irish-bishops/" rel="bookmark" title="Bedridden Woman Healed at Knock Shrine in First-Ever Approved Miracle by Irish Bishops"><img width="198" height="143" itemprop="image" class="entry-thumb" src="https://churchpop.com/wp-content/uploads/2019/09/knock-shrine-marian-apparition-198x143.jpg" alt="" title="Bedridden Woman Healed at Knock Shrine in First-Ever Approved Miracle by Irish Bishops" /></a></div>
<div class="item-details">
<h4 itemprop="name" class="entry-title"><a itemprop="url" href="https://churchpop.com/2019/09/12/bedridden-woman-healed-at-knock-shrine-in-first-ever-approved-miracle-by-irish-bishops/" rel="bookmark" title="Bedridden Woman Healed at Knock Shrine in First-Ever Approved Miracle by Irish Bishops">Bedridden Woman Healed at Knock Shrine in First-Ever Approved Miracle by Irish Bishops</a></h4>
</div>
</div>
</div><div class="td-next-prev-wrap"><a href="#" class="td_ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_5d8082291f1fa" data-td_block_id="td_uid_1_5d8082291f1fa"></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_1_5d8082291f1fa" data-td_block_id="td_uid_1_5d8082291f1fa"></a></div><div class="clearfix"></div></div> </div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-not-mega td-mega-menu menu-item-20"><a href="https://churchpop.com/category/lists/">Lists</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-mega-grid"><script>var block_td_uid_3_5d8082292348f = new td_block();
block_td_uid_3_5d8082292348f.id = "td_uid_3_5d8082292348f";
block_td_uid_3_5d8082292348f.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"3","show_child_cat":"5"}';
block_td_uid_3_5d8082292348f.td_cur_cat = "3";
block_td_uid_3_5d8082292348f.td_column_number = "1";
block_td_uid_3_5d8082292348f.block_type = "td_mega_menu";
block_td_uid_3_5d8082292348f.post_count = "5";
block_td_uid_3_5d8082292348f.found_posts = "427";
block_td_uid_3_5d8082292348f.max_num_pages = "86";
td_blocks.push(block_td_uid_3_5d8082292348f);
</script><div class="td_block_wrap td_block_mega_menu td-no-subcats"><div id=td_uid_3_5d8082292348f class="td_block_inner">
<div class="td_mod_mega_menu">
<div class="thumb-wrap"><a href="https://churchpop.com/2019/08/11/happy-5th-birthday-churchpop-heres-some-of-our-best-articles-ever/" rel="bookmark" title="Happy 5th Birthday, ChurchPOP! Here&#8217;s Some of Our Best Content Ever"><img width="198" height="143" itemprop="image" class="entry-thumb" src="https://churchpop.com/wp-content/uploads/2019/08/top-10-articles-198x143.jpg" alt="" title="Happy 5th Birthday, ChurchPOP! Here&#8217;s Some of Our Best Content Ever" /></a></div>
<div class="item-details">
<h4 itemprop="name" class="entry-title"><a itemprop="url" href="https://churchpop.com/2019/08/11/happy-5th-birthday-churchpop-heres-some-of-our-best-articles-ever/" rel="bookmark" title="Happy 5th Birthday, ChurchPOP! Here&#8217;s Some of Our Best Content Ever">Happy 5th Birthday, ChurchPOP! Here&#8217;s Some of Our Best Content Ever</a></h4>
</div>
</div>
<div class="td_mod_mega_menu">
<div class="thumb-wrap"><a href="https://churchpop.com/2019/05/25/6-of-the-weirdest-notre-dame-renovation-proposals/" rel="bookmark" title="Rooftop Swimming Pool at Notre Dame? Here’s 6 Bizarre Renovation Proposals"><img width="198" height="143" itemprop="image" class="entry-thumb" src="https://churchpop.com/wp-content/uploads/2019/05/notre-dame-featured1-198x143.jpg" alt="" title="Rooftop Swimming Pool at Notre Dame? Here’s 6 Bizarre Renovation Proposals" /></a></div>
<div class="item-details">
<h4 itemprop="name" class="entry-title"><a itemprop="url" href="https://churchpop.com/2019/05/25/6-of-the-weirdest-notre-dame-renovation-proposals/" rel="bookmark" title="Rooftop Swimming Pool at Notre Dame? Here’s 6 Bizarre Renovation Proposals">Rooftop Swimming Pool at Notre Dame? Here’s 6 Bizarre Renovation Proposals</a></h4>
</div>
</div>
<div class="td_mod_mega_menu">
<div class="thumb-wrap"><a href="https://churchpop.com/2019/01/30/is-missing-mass-okay-because-of-bad-weather-3-things-to-consider-according-to-this-parish-priest/" rel="bookmark" title="Is Missing Mass Okay Because of Bad Weather? 3 Things to Consider, According to This Parish Priest"><img width="198" height="143" itemprop="image" class="entry-thumb" src="https://churchpop.com/wp-content/uploads/2019/01/bad-weather-Mass-1-198x143.jpg" alt="" title="Is Missing Mass Okay Because of Bad Weather? 3 Things to Consider, According to This Parish Priest" /></a></div>
<div class="item-details">
<h4 itemprop="name" class="entry-title"><a itemprop="url" href="https://churchpop.com/2019/01/30/is-missing-mass-okay-because-of-bad-weather-3-things-to-consider-according-to-this-parish-priest/" rel="bookmark" title="Is Missing Mass Okay Because of Bad Weather? 3 Things to Consider, According to This Parish Priest">Is Missing Mass Okay Because of Bad Weather? 3 Things to Consider, According to This Parish Priest</a></h4>
</div>
</div>
<div class="td_mod_mega_menu">
<div class="thumb-wrap"><a href="https://churchpop.com/2019/01/16/teach-him-virtue-this-priests-epic-response-to-gillettes-toxic-masculinity-ad/" rel="bookmark" title="&#8220;Teach Him Virtue&#8221;: This Priest&#8217;s Epic Response to Gillette&#8217;s &#8216;Toxic Masculinity&#8217; Ad"><img width="198" height="143" itemprop="image" class="entry-thumb" src="https://churchpop.com/wp-content/uploads/2019/01/toxic-male2-198x143.jpg" alt="" title="&#8220;Teach Him Virtue&#8221;: This Priest&#8217;s Epic Response to Gillette&#8217;s &#8216;Toxic Masculinity&#8217; Ad" /></a></div>
<div class="item-details">
<h4 itemprop="name" class="entry-title"><a itemprop="url" href="https://churchpop.com/2019/01/16/teach-him-virtue-this-priests-epic-response-to-gillettes-toxic-masculinity-ad/" rel="bookmark" title="&#8220;Teach Him Virtue&#8221;: This Priest&#8217;s Epic Response to Gillette&#8217;s &#8216;Toxic Masculinity&#8217; Ad">&#8220;Teach Him Virtue&#8221;: This Priest&#8217;s Epic Response to Gillette&#8217;s &#8216;Toxic Masculinity&#8217; Ad</a></h4>
</div>
</div>
<div class="td_mod_mega_menu">
<div class="thumb-wrap"><a href="https://churchpop.com/2018/12/21/when-god-says-no-10-ways-to-make-petitionary-prayers-more-effective/" rel="bookmark" title="&#8220;When God Says No&#8221;: 10 Ways to Make Petitionary Prayers More Effective"><img width="198" height="143" itemprop="image" class="entry-thumb" src="https://churchpop.com/wp-content/uploads/2018/12/When-God-says-no2-198x143.jpg" alt="" title="&#8220;When God Says No&#8221;: 10 Ways to Make Petitionary Prayers More Effective" /></a></div>
<div class="item-details">
<h4 itemprop="name" class="entry-title"><a itemprop="url" href="https://churchpop.com/2018/12/21/when-god-says-no-10-ways-to-make-petitionary-prayers-more-effective/" rel="bookmark" title="&#8220;When God Says No&#8221;: 10 Ways to Make Petitionary Prayers More Effective">&#8220;When God Says No&#8221;: 10 Ways to Make Petitionary Prayers More Effective</a></h4>
</div>
</div>
</div><div class="td-next-prev-wrap"><a href="#" class="td_ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_3_5d8082292348f" data-td_block_id="td_uid_3_5d8082292348f"></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_3_5d8082292348f" data-td_block_id="td_uid_3_5d8082292348f"></a></div><div class="clearfix"></div></div> </div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-not-mega td-mega-menu menu-item-19182"><a href="https://churchpop.com/category/video-games/">Games</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-mega-grid"><script>var block_td_uid_5_5d80822926fbc = new td_block();
block_td_uid_5_5d80822926fbc.id = "td_uid_5_5d80822926fbc";
block_td_uid_5_5d80822926fbc.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"6310","show_child_cat":"5"}';
block_td_uid_5_5d80822926fbc.td_cur_cat = "6310";
block_td_uid_5_5d80822926fbc.td_column_number = "1";
block_td_uid_5_5d80822926fbc.block_type = "td_mega_menu";
block_td_uid_5_5d80822926fbc.post_count = "2";
block_td_uid_5_5d80822926fbc.found_posts = "2";
block_td_uid_5_5d80822926fbc.max_num_pages = "1";
td_blocks.push(block_td_uid_5_5d80822926fbc);
</script><div class="td_block_wrap td_block_mega_menu td-no-subcats"><div id=td_uid_5_5d80822926fbc class="td_block_inner">
<div class="td_mod_mega_menu">
<div class="thumb-wrap"><a href="https://churchpop.com/2016/09/25/friar-dude/" rel="bookmark" title="Friar Dude: Super Fun Catholic Franciscan Video Game"><img width="198" height="143" itemprop="image" class="entry-thumb" src="https://churchpop.com/wp-content/uploads/2016/03/123-16-198x143.jpg" alt="" title="Friar Dude: Super Fun Catholic Franciscan Video Game" /></a></div>
<div class="item-details">
<h4 itemprop="name" class="entry-title"><a itemprop="url" href="https://churchpop.com/2016/09/25/friar-dude/" rel="bookmark" title="Friar Dude: Super Fun Catholic Franciscan Video Game">Friar Dude: Super Fun Catholic Franciscan Video Game</a></h4>
</div>
</div>
<div class="td_mod_mega_menu">
<div class="thumb-wrap"><a href="https://churchpop.com/2016/09/25/passiontide-super-cool-catholic-dominican-video-game/" rel="bookmark" title="Passiontide: Super Cool Catholic Dominican Video Game!"><img width="198" height="143" itemprop="image" class="entry-thumb" src="https://churchpop.com/wp-content/uploads/2016/02/123-17-198x143.jpg" alt="" title="Passiontide: Super Cool Catholic Dominican Video Game!" /></a></div>
<div class="item-details">
<h4 itemprop="name" class="entry-title"><a itemprop="url" href="https://churchpop.com/2016/09/25/passiontide-super-cool-catholic-dominican-video-game/" rel="bookmark" title="Passiontide: Super Cool Catholic Dominican Video Game!">Passiontide: Super Cool Catholic Dominican Video Game!</a></h4>
</div>
</div>
</div><div class="td-next-prev-wrap"><a href="#" class="td_ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_5_5d80822926fbc" data-td_block_id="td_uid_5_5d80822926fbc"></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_5_5d80822926fbc" data-td_block_id="td_uid_5_5d80822926fbc"></a></div><div class="clearfix"></div></div> </div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-not-mega td-mega-menu menu-item-557"><a href="https://churchpop.com/category/quizzes/">Quizzes</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-mega-grid"><script>var block_td_uid_7_5d80822927b91 = new td_block();
block_td_uid_7_5d80822927b91.id = "td_uid_7_5d80822927b91";
block_td_uid_7_5d80822927b91.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"210","show_child_cat":"5"}';
block_td_uid_7_5d80822927b91.td_cur_cat = "210";
block_td_uid_7_5d80822927b91.td_column_number = "1";
block_td_uid_7_5d80822927b91.block_type = "td_mega_menu";
block_td_uid_7_5d80822927b91.post_count = "5";
block_td_uid_7_5d80822927b91.found_posts = "31";
block_td_uid_7_5d80822927b91.max_num_pages = "7";
td_blocks.push(block_td_uid_7_5d80822927b91);
</script><div class="td_block_wrap td_block_mega_menu td-no-subcats"><div id=td_uid_7_5d80822927b91 class="td_block_inner">
<div class="td_mod_mega_menu">
<div class="thumb-wrap"><a href="https://churchpop.com/2017/05/02/quiz-can-you-identify-these-american-born-venerables-on-the-path-to-sainthood/" rel="bookmark" title="QUIZ: Can You Identify These American-Born Venerables on the Path to Sainthood?"><img width="198" height="143" itemprop="image" class="entry-thumb" src="https://churchpop.com/wp-content/uploads/2017/05/american-venerables-198x143.jpg" alt="" title="QUIZ: Can You Identify These American-Born Venerables on the Path to Sainthood?" /></a></div>
<div class="item-details">
<h4 itemprop="name" class="entry-title"><a itemprop="url" href="https://churchpop.com/2017/05/02/quiz-can-you-identify-these-american-born-venerables-on-the-path-to-sainthood/" rel="bookmark" title="QUIZ: Can You Identify These American-Born Venerables on the Path to Sainthood?">QUIZ: Can You Identify These American-Born Venerables on the Path to Sainthood?</a></h4>
</div>
</div>
<div class="td_mod_mega_menu">
<div class="thumb-wrap"><a href="https://churchpop.com/2017/03/30/quiz-name-heresy-make-sure-dont-believe/" rel="bookmark" title="QUIZ: Name that Heresy! (Then Make Sure You Don&#8217;t Believe Them&#8230;)"><img width="198" height="143" itemprop="image" class="entry-thumb" src="https://churchpop.com/wp-content/uploads/2017/03/heretics-198x143.jpg" alt="" title="QUIZ: Name that Heresy! (Then Make Sure You Don&#8217;t Believe Them&#8230;)" /></a></div>
<div class="item-details">
<h4 itemprop="name" class="entry-title"><a itemprop="url" href="https://churchpop.com/2017/03/30/quiz-name-heresy-make-sure-dont-believe/" rel="bookmark" title="QUIZ: Name that Heresy! (Then Make Sure You Don&#8217;t Believe Them&#8230;)">QUIZ: Name that Heresy! (Then Make Sure You Don&#8217;t Believe Them&#8230;)</a></h4>
</div>
</div>
<div class="td_mod_mega_menu">
<div class="thumb-wrap"><a href="https://churchpop.com/2017/01/05/quiz-obscure-saint-new-saint-buddy/" rel="bookmark" title="QUIZ: Which Obscure Saint Should Be Your New Saint Buddy?"><img width="198" height="143" itemprop="image" class="entry-thumb" src="https://churchpop.com/wp-content/uploads/2017/01/saints-198x143.jpg" alt="" title="QUIZ: Which Obscure Saint Should Be Your New Saint Buddy?" /></a></div>
<div class="item-details">
<h4 itemprop="name" class="entry-title"><a itemprop="url" href="https://churchpop.com/2017/01/05/quiz-obscure-saint-new-saint-buddy/" rel="bookmark" title="QUIZ: Which Obscure Saint Should Be Your New Saint Buddy?">QUIZ: Which Obscure Saint Should Be Your New Saint Buddy?</a></h4>
</div>
</div>
<div class="td_mod_mega_menu">
<div class="thumb-wrap"><a href="https://churchpop.com/2017/01/03/quiz-devotion-personality/" rel="bookmark" title="QUIZ: Which Catholic Devotion Best Fits Your Personality?"><img width="198" height="143" itemprop="image" class="entry-thumb" src="https://churchpop.com/wp-content/uploads/2017/01/quiz-198x143.jpg" alt="" title="QUIZ: Which Catholic Devotion Best Fits Your Personality?" /></a></div>
<div class="item-details">
<h4 itemprop="name" class="entry-title"><a itemprop="url" href="https://churchpop.com/2017/01/03/quiz-devotion-personality/" rel="bookmark" title="QUIZ: Which Catholic Devotion Best Fits Your Personality?">QUIZ: Which Catholic Devotion Best Fits Your Personality?</a></h4>
</div>
</div>
<div class="td_mod_mega_menu">
<div class="thumb-wrap"><a href="https://churchpop.com/2016/10/13/can-pass-bible-literacy-quiz/" rel="bookmark" title="Can You Pass This Biblical Literacy Quiz?"><img width="198" height="143" itemprop="image" class="entry-thumb" src="https://churchpop.com/wp-content/uploads/2016/10/2-2-198x143.jpg" alt="" title="Can You Pass This Biblical Literacy Quiz?" /></a></div>
<div class="item-details">
<h4 itemprop="name" class="entry-title"><a itemprop="url" href="https://churchpop.com/2016/10/13/can-pass-bible-literacy-quiz/" rel="bookmark" title="Can You Pass This Biblical Literacy Quiz?">Can You Pass This Biblical Literacy Quiz?</a></h4>
</div>
</div>
</div><div class="td-next-prev-wrap"><a href="#" class="td_ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_7_5d80822927b91" data-td_block_id="td_uid_7_5d80822927b91"></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_7_5d80822927b91" data-td_block_id="td_uid_7_5d80822927b91"></a></div><div class="clearfix"></div></div> </div></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-has-children td-not-mega menu-item-12416"><a href="https://churchpop.com/">More</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-not-mega menu-item-9659"><a href="https://churchpop.com/category/comics/">Comics</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-not-mega menu-item-9661"><a href="https://churchpop.com/category/infographics/">Infographics</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-not-mega menu-item-156"><a href="https://churchpop.com/category/videos/">Videos</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-no-down-arrow td-not-mega menu-item-176"><a href="https://churchpop.com/about/"><span class="menu_icon td-sp td-sp-ico-categ"></span><span class="menu_hidden">Categories</span></a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-post_type menu-item-object-page td-not-mega menu-item-177"><a href="https://churchpop.com/about/">About</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-not-mega menu-item-217"><a href="https://churchpop.com/submissionstips/">Submissions/Tips</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-not-mega menu-item-15921"><a href="http://ewtnadvertising.com/churchpop-com/">Advertising</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-not-mega menu-item-178"><a href="https://churchpop.com/contact/">Contact</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-not-mega menu-item-13098"><a href="http://es.churchpop.com">ChurchPOP Español</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-not-mega menu-item-15030"><a href="http://pt.churchpop.com">ChurchPOP Português</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-not-mega menu-item-22709"><a href="http://it.churchpop.com/">ChurchPOP Italiano</a></li>
</ul>
</li>
</ul></div> </div>
<div id="td-top-search">

<div class="header-search-wrap">
<div class="dropdown header-search">
<a id="search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><span class="td-sp td-sp-ico-search"></span></a>
<div class="dropdown-menu" aria-labelledby="search-button">
<form role="search" method="get" class="td-search-form" action="https://churchpop.com/">
<div class="td-head-form-search-wrap">
<input class="needsclick" id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
</div>
</form>
<div id="td-aj-search"></div>
</div>
</div>
</div>
</div>
</div>
<div id="support-churchpop">
<ul id="menu-donation" class="sf-menu sf-js-enabled">
<li class="menu-item menu-item-type-post_type menu-item-object-page td-no-down-arrow td-not-mega menu-item-donation"><a href="https://sd.churchpop.com/churchpop/">Support ChurchPOP</a></li>
</ul>
</div>
</div> 
</div> 
</div> 
</div> <div class="container header-content-rec">
<div class="row">
<div class="span12">
</div>
</div>
</div>
<div class="container td-page-wrap">
<div class="row">
<div class="span12">
<div class="td-grid-wrap">
<div class="container-fluid">
<div class="row-fluid ">
<div class="span8 column_container td-post-content" role="main" itemprop="mainContentOfPage">
<div data-io-article-url="https://churchpop.com/2019/09/14/houston-priest-beaten-after-gun-fails-to-fire-says-divine-intervention-saved-his-life-i-should-be-dead/">
<article id="post-32710" class="post-32710 post type-post status-publish format-standard has-post-thumbnail hentry category-articles category-featured category-news-2 tag-bible-2 tag-catholic tag-catholic-church tag-catholic-priests tag-catholicism tag-catholics tag-christ tag-christian tag-christianity tag-christians tag-church tag-churches tag-crime tag-crime-stories tag-criminal tag-faith tag-god tag-gospel-2 tag-history-2 tag-houston tag-houston-police-department tag-houston-texas tag-houston-tx tag-jesus tag-jesus-christ tag-life-saving tag-love tag-mass tag-miracle tag-police-officer tag-pray tag-prayer tag-priest tag-priest-assaulted tag-priest-attacked tag-priest-life tag-priest-saved tag-priests tag-pro-life-2 tag-prolife tag-saint tag-saints tag-scripture tag-supernatural-2 tag-suspect tag-suspect-taken-into-custody tag-texas tag-video tag-videos-2" itemscope itemtype="http://schema.org/Article">
<header>
<h1 itemprop="name" class="entry-title">Texas Priest Miraculously Survives Attempted Shooting, Suspects’ Gun Fails to Fire Three Times</h1> <div class="meta-info">
<ul class="td-category"><li class="entry-category"><a style="background-color:#efcf00;" href="https://churchpop.com/category/articles/">Articles</a></li><li class="entry-category"><a href="https://churchpop.com/category/news-2/">News</a></li></ul> <div class="td-clear-author"></div><span class="td-block-author">by <a itemprop="author" href="https://churchpop.com/author/editor/">ChurchPOP Editor</a> - </span><meta itemprop="interactionCount" content="UserComments:0" /> <time itemprop="dateCreated" class="entry-date updated" datetime="2019-09-14T14:42:22+00:00">September 14, 2019</time><meta itemprop="interactionCount" content="UserComments:0" /> <div class="entry-comments-views"></div> </div>
</header>
<div class="td-post-featured-image"><figure><img width="700" height="438" itemprop="image" class="entry-thumb" src="https://churchpop.com/wp-content/uploads/2019/09/Priest-rosary2-700x438.jpg" alt="" title="Priest rosary2" /><figcaption class="wp-caption-text"><a href=https://twitter.com/JeffEhlingABC13/status/1172498509150527493">@JeffEhlingABC13, Twitter</a> / ChurchPOP</figcaption></figure></div> <div class="td-post-text-content">
<div class="td-a-rec td-a-rec-id-content_top  td-rec-hide-on-m td-rec-hide-on-tl td-rec-hide-on-tp">
<div id='div-gpt-ad-1493839612370-0' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1493839612370-0'); });
</script>
</div></div><p>What an amazing miracle!</p>
<p>While holding out his rosary, Rev. Desmond Ohankwere credits &#8220;divine intervention&#8221; for saving his life after four men assaulted him at gunpoint outside his home near St. Peter the Apostle Catholic Church in Houston.</p>
<p>The <a href="https://www.apnews.com/059e88d19faf4de6b87ab57fb071d6d6" target="_blank" rel="noopener">Associated Press</a> reported that the four men involved first stole an SUV from a gas station while the owner filled it with fuel.  They then encountered the priest walking and praying the rosary in a nearby Catholic Church parking lot after the SUV ran out of gas.</p>
<p>The men robbed him, taking his keys and two cell phones. <strong>However, they did not take his rosary. </strong></p>
<p>On his knees praying for God to spare is life, the suspect attempted to fire the gun twice, pointing it to his head. The trigger failed both times.</p>
<p>&#8220;When he clicked it, I thought I was gone, so then he tried it again,” Fr. Ohankwere <a href="https://www.khou.com/article/news/crime/priest-beaten-by-robbery-suspects-who-later-shot-houston-police-officer/285-fff58c3c-c8ad-42a8-a47e-3defb5c2a022" target="_blank" rel="noopener">told KHOU 11</a> of Houston. &#8220;I should be dead now. You should be talking about my burial.&#8221;</p>
<p>The men then beat the priest after the trigger misfired. Fr. Ohankwere said they even tried firing the gun a third time, but the gun again failed to fire.</p>
<p>Fr. Ohankwere now has bruises and scrapes on his head, arm and lower body, but God answered his prayers.</p>
<h4><strong>Fr. Ohankwere tells his story below:</strong></h4>
<p><iframe src="https://www.youtube.com/embed/W4yG8YeySVo" width="853" height="480" frameborder="0" allowfullscreen="allowfullscreen"></iframe><br />
<em><a href="https://www.youtube.com/watch?v=W4yG8YeySVo">Click here if you cannot see the video above. </a></em></p>
<p>Following Fr. Ohankwere&#8217;s attack, the men also <a href="https://www.apnews.com/059e88d19faf4de6b87ab57fb071d6d6" target="_blank" rel="noopener">robbed</a> a woman and stole her pickup. One of the suspects then shot a 29-year-old police officer three times with the officer&#8217;s weapon. Another officer then shot and killed one of the suspects, and they took two more into custody. Police are still searching for one suspect at large.</p>
<p>The 29-year-old officer is <a href="https://abc13.com/hpd-officer-walking-after-being-shot-3-times/5536540/" target="_blank" rel="noopener">now walking</a> and in stable condition.</p>
<h4><strong>Let us pray for all those involved!</strong></h4>
<p><strong>[See also: <a href="https://churchpop.com/2019/07/29/priest-brutally-attacked-with-rosary-in-polish-church-i-was-flooded-with-blood/">Priest Brutally Attacked With Rosary in Polish Church: “I Was Flooded With Blood”</a>]</strong></p>
<p><strong>[See also: <a href="https://churchpop.com/2019/07/14/famous-priest-shoved-off-stage-in-attack-at-major-brazilian-event-video-inside/">Famous Priest Shoved Off Stage in Attack at Major Brazilian Event (Video Inside)</a>]</strong></p>
<div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://churchpop.com/2019/09/14/houston-priest-beaten-after-gun-fails-to-fire-says-divine-intervention-saved-his-life-i-should-be-dead/" data-a2a-title="Texas Priest Miraculously Survives Attempted Shooting, Suspects’ Gun Fails to Fire Three Times"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fchurchpop.com%2F2019%2F09%2F14%2Fhouston-priest-beaten-after-gun-fails-to-fire-says-divine-intervention-saved-his-life-i-should-be-dead%2F&amp;linkname=Texas%20Priest%20Miraculously%20Survives%20Attempted%20Shooting%2C%20Suspects%E2%80%99%20Gun%20Fails%20to%20Fire%20Three%20Times" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fchurchpop.com%2F2019%2F09%2F14%2Fhouston-priest-beaten-after-gun-fails-to-fire-says-divine-intervention-saved-his-life-i-should-be-dead%2F&amp;linkname=Texas%20Priest%20Miraculously%20Survives%20Attempted%20Shooting%2C%20Suspects%E2%80%99%20Gun%20Fails%20to%20Fire%20Three%20Times" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_whatsapp" href="https://www.addtoany.com/add_to/whatsapp?linkurl=https%3A%2F%2Fchurchpop.com%2F2019%2F09%2F14%2Fhouston-priest-beaten-after-gun-fails-to-fire-says-divine-intervention-saved-his-life-i-should-be-dead%2F&amp;linkname=Texas%20Priest%20Miraculously%20Survives%20Attempted%20Shooting%2C%20Suspects%E2%80%99%20Gun%20Fails%20to%20Fire%20Three%20Times" title="WhatsApp" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fchurchpop.com%2F2019%2F09%2F14%2Fhouston-priest-beaten-after-gun-fails-to-fire-says-divine-intervention-saved-his-life-i-should-be-dead%2F&amp;linkname=Texas%20Priest%20Miraculously%20Survives%20Attempted%20Shooting%2C%20Suspects%E2%80%99%20Gun%20Fails%20to%20Fire%20Three%20Times" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_print" href="https://www.addtoany.com/add_to/print?linkurl=https%3A%2F%2Fchurchpop.com%2F2019%2F09%2F14%2Fhouston-priest-beaten-after-gun-fails-to-fire-says-divine-intervention-saved-his-life-i-should-be-dead%2F&amp;linkname=Texas%20Priest%20Miraculously%20Survives%20Attempted%20Shooting%2C%20Suspects%E2%80%99%20Gun%20Fails%20to%20Fire%20Three%20Times" title="Print" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div> </div>
<div class="popup-embedded-box-gfcr-1 popupally-outer-embedded-gfcr-1 class-placeholder-jehjsq-1">
<!--[if lte IE 8]>
            <script charset="utf-8" type="text/javascript" src="//js.hsforms.net/forms/v2-legacy.js"></script>
            <![endif]-->
<script charset="utf-8" type="text/javascript" src="//js.hsforms.net/forms/v2.js"></script>
<script>
/*                hbspt.forms.create({
                   portalId: "4395239",
                   formId: "211afb4f-7e85-41eb-9ce1-630fbaf5efff"
                }); */
            </script>
</div>
<div class="clearfix"></div>
<footer>
<div class="td-social-sharing">
</div> <div class="author-box-wrap"><a href="https://churchpop.com/author/editor/"><img src="https://churchpop.com/wp-content/uploads/2017/04/circle-gradiant-150x150.png" width="106" height="106" alt="Avatar" class="avatar avatar-106 wp-user-avatar wp-user-avatar-106 photo avatar-default" /></a><div class="desc"><div class="td-author-name"><a href="https://churchpop.com/author/editor/">ChurchPOP Editor</a></div><div class="vcard author"><span class="fn">Make holy all the things!</span></div><div class="td-author-social"><span class="td-social-icon-wrap"><a href="https://www.facebook.com/churchpopsite"><span class="td-social-s4-16 td-s-s-16-facebook"></span></a></span><span class="td-social-icon-wrap"><a href="https://www.instagram.com/churchpop/"><span class="td-social-s4-16 td-s-s-16-instagram"></span></a></span><span class="td-social-icon-wrap"><a href="https://feeds.feedburner.com/churchpop"><span class="td-social-s4-16 td-s-s-16-rss"></span></a></span><span class="td-social-icon-wrap"><a href="https://twitter.com/Church_POP"><span class="td-social-s4-16 td-s-s-16-twitter"></span></a></span></div><div class="clearfix"></div></div></div>
<meta itemprop="author" content="ChurchPOP Editor"> </footer>
</article>
</div>
<div class="popup-embedded-box-gfcr-1 popupally-outer-embedded-gfcr-1 class-placeholder-jehjsq-1" style="display:none"></div>

<div class="art-img-text-down similar-articles"><h4 class="block-title"><span>SIMILAR ARTICLES</span></h4>
<div class="wpb_row row-fluid">
<div class="span6">
<div class="td_mod6 td_mod_wrap " itemscope itemtype="https://schema.org/Article">
<div class="thumb-wrap"><a href="https://churchpop.com/2019/09/16/sit-stand-or-kneel-your-how-to-guide-for-moving-at-mass-in-one-infographic/" rel="bookmark" title="Sit, Stand, or Kneel? Your How-To Guide For Moving At Mass, in One Infographic"><img width="326" height="159" itemprop="image" class="entry-thumb" src="https://churchpop.com/wp-content/uploads/2019/09/infographic-instruction-manual-mass-2-326x159.jpg" alt="" title="Sit, Stand, or Kneel? Your How-To Guide For Moving At Mass, in One Infographic" /></a></div>
<h3 itemprop="name" class="entry-title"><a itemprop="url" href="https://churchpop.com/2019/09/16/sit-stand-or-kneel-your-how-to-guide-for-moving-at-mass-in-one-infographic/" rel="bookmark" title="Sit, Stand, or Kneel? Your How-To Guide For Moving At Mass, in One Infographic">Sit, Stand, or Kneel? Your How-To Guide For Moving At Mass, in One Infographic</a></h3>
<div class="meta-info">
<time itemprop="dateCreated" class="entry-date updated" datetime="2019-09-16T11:00:25+00:00">September 16, 2019</time><meta itemprop="interactionCount" content="UserComments:0" />
<div class="entry-comments-views"></div>
</div>
<meta itemprop="author" content="ChurchPOP Editor">
</div>
</div> 
<div class="span6">
<div class="td_mod6 td_mod_wrap " itemscope itemtype="https://schema.org/Article">
<div class="thumb-wrap"><a href="https://churchpop.com/2019/09/15/how-can-i-be-gay-catholic-one-gay-womans-powerful-advice-to-those-with-same-sex-attraction/" rel="bookmark" title="&#8220;Can I Be Gay &#038; Catholic?&#8221;: One Woman&#8217;s Powerful Advice for Catholics With Same-Sex Attraction"><img width="326" height="159" itemprop="image" class="entry-thumb" src="https://churchpop.com/wp-content/uploads/2019/09/maxresdefault-1-326x159.jpg" alt="" title="&#8220;Can I Be Gay &#038; Catholic?&#8221;: One Woman&#8217;s Powerful Advice for Catholics With Same-Sex Attraction" /></a></div>
<h3 itemprop="name" class="entry-title"><a itemprop="url" href="https://churchpop.com/2019/09/15/how-can-i-be-gay-catholic-one-gay-womans-powerful-advice-to-those-with-same-sex-attraction/" rel="bookmark" title="&#8220;Can I Be Gay &#038; Catholic?&#8221;: One Woman&#8217;s Powerful Advice for Catholics With Same-Sex Attraction">&#8220;Can I Be Gay &#038; Catholic?&#8221;: One Woman&#8217;s Powerful Advice for Catholics With Same-Sex Attraction</a></h3>
<div class="meta-info">
<time itemprop="dateCreated" class="entry-date updated" datetime="2019-09-15T09:00:07+00:00">September 15, 2019</time><meta itemprop="interactionCount" content="UserComments:0" />
<div class="entry-comments-views"></div>
</div>
<meta itemprop="author" content="ChurchPOP Editor">
</div>
</div> </div>
<div class="wpb_row row-fluid">
<div class="span6">
<div class="td_mod6 td_mod_wrap " itemscope itemtype="https://schema.org/Article">
<div class="thumb-wrap"><a href="https://churchpop.com/2019/09/13/this-married-catholic-priest-powerfully-explains-why-priests-should-be-celibate/" rel="bookmark" title="This Married Catholic Priest Powerfully Explains Why Priests SHOULD Be Celibate"><img width="326" height="159" itemprop="image" class="entry-thumb" src="https://churchpop.com/wp-content/uploads/2019/09/maxresdefault-326x159.jpg" alt="" title="This Married Catholic Priest Powerfully Explains Why Priests SHOULD Be Celibate" /></a></div>
<h3 itemprop="name" class="entry-title"><a itemprop="url" href="https://churchpop.com/2019/09/13/this-married-catholic-priest-powerfully-explains-why-priests-should-be-celibate/" rel="bookmark" title="This Married Catholic Priest Powerfully Explains Why Priests SHOULD Be Celibate">This Married Catholic Priest Powerfully Explains Why Priests SHOULD Be Celibate</a></h3>
<div class="meta-info">
<time itemprop="dateCreated" class="entry-date updated" datetime="2019-09-13T13:59:39+00:00">September 13, 2019</time><meta itemprop="interactionCount" content="UserComments:0" />
<div class="entry-comments-views"></div>
</div>
<meta itemprop="author" content="ChurchPOP Editor">
</div>
</div> 
<div class="span6">
<div class="td_mod6 td_mod_wrap " itemscope itemtype="https://schema.org/Article">
<div class="thumb-wrap"><a href="https://churchpop.com/2019/09/12/bedridden-woman-healed-at-knock-shrine-in-first-ever-approved-miracle-by-irish-bishops/" rel="bookmark" title="Bedridden Woman Healed at Knock Shrine in First-Ever Approved Miracle by Irish Bishops"><img width="326" height="159" itemprop="image" class="entry-thumb" src="https://churchpop.com/wp-content/uploads/2019/09/knock-shrine-marian-apparition-326x159.jpg" alt="" title="Bedridden Woman Healed at Knock Shrine in First-Ever Approved Miracle by Irish Bishops" /></a></div>
<h3 itemprop="name" class="entry-title"><a itemprop="url" href="https://churchpop.com/2019/09/12/bedridden-woman-healed-at-knock-shrine-in-first-ever-approved-miracle-by-irish-bishops/" rel="bookmark" title="Bedridden Woman Healed at Knock Shrine in First-Ever Approved Miracle by Irish Bishops">Bedridden Woman Healed at Knock Shrine in First-Ever Approved Miracle by Irish Bishops</a></h3>
<div class="meta-info">
<time itemprop="dateCreated" class="entry-date updated" datetime="2019-09-12T15:06:48+00:00">September 12, 2019</time><meta itemprop="interactionCount" content="UserComments:0" />
<div class="entry-comments-views"></div>
</div>
<meta itemprop="author" content="Catholic News Agency">
</div>
</div> </div>
<div class="wpb_row row-fluid">
<div class="span6">
<div class="td_mod6 td_mod_wrap " itemscope itemtype="https://schema.org/Article">
<div class="thumb-wrap"><a href="https://churchpop.com/2019/09/10/priest-offers-golf-cart-confessions-on-the-go-on-college-campus-lets-get-out-to-the-people/" rel="bookmark" title="Priest Offers Golf Cart &#8220;Confessions On-The-Go&#8221; on College Campus: &#8220;Let&#8217;s Get Out to the People&#8221;"><img width="326" height="159" itemprop="image" class="entry-thumb" src="https://churchpop.com/wp-content/uploads/2019/09/golf-cart-confessions-326x159.jpg" alt="" title="Priest Offers Golf Cart &#8220;Confessions On-The-Go&#8221; on College Campus: &#8220;Let&#8217;s Get Out to the People&#8221;" /></a></div>
<h3 itemprop="name" class="entry-title"><a itemprop="url" href="https://churchpop.com/2019/09/10/priest-offers-golf-cart-confessions-on-the-go-on-college-campus-lets-get-out-to-the-people/" rel="bookmark" title="Priest Offers Golf Cart &#8220;Confessions On-The-Go&#8221; on College Campus: &#8220;Let&#8217;s Get Out to the People&#8221;">Priest Offers Golf Cart &#8220;Confessions On-The-Go&#8221; on College Campus: &#8220;Let&#8217;s Get Out to the People&#8221;</a></h3>
<div class="meta-info">
<time itemprop="dateCreated" class="entry-date updated" datetime="2019-09-10T14:42:49+00:00">September 10, 2019</time><meta itemprop="interactionCount" content="UserComments:0" />
<div class="entry-comments-views"></div>
</div>
<meta itemprop="author" content="ChurchPOP Editor">
</div>
</div> 
<div class="span6">
<div class="td_mod6 td_mod_wrap " itemscope itemtype="https://schema.org/Article">
<div class="thumb-wrap"><a href="https://churchpop.com/2019/09/09/priest-reveals-how-one-powerful-photo-changed-his-life-forever-dont-be-afraid-of-confession/" rel="bookmark" title="Priest Reveals How One Powerful Photo Changed His Life Forever: &#8220;Don&#8217;t Be Afraid of Confession&#8221;"><img width="326" height="159" itemprop="image" class="entry-thumb" src="https://churchpop.com/wp-content/uploads/2019/09/confession-fr-goyo-326x159.jpg" alt="" title="Priest Reveals How One Powerful Photo Changed His Life Forever: &#8220;Don&#8217;t Be Afraid of Confession&#8221;" /></a></div>
<h3 itemprop="name" class="entry-title"><a itemprop="url" href="https://churchpop.com/2019/09/09/priest-reveals-how-one-powerful-photo-changed-his-life-forever-dont-be-afraid-of-confession/" rel="bookmark" title="Priest Reveals How One Powerful Photo Changed His Life Forever: &#8220;Don&#8217;t Be Afraid of Confession&#8221;">Priest Reveals How One Powerful Photo Changed His Life Forever: &#8220;Don&#8217;t Be Afraid of Confession&#8221;</a></h3>
<div class="meta-info">
<time itemprop="dateCreated" class="entry-date updated" datetime="2019-09-09T11:00:17+00:00">September 9, 2019</time><meta itemprop="interactionCount" content="UserComments:0" />
<div class="entry-comments-views"></div>
</div>
<meta itemprop="author" content="ChurchPOP Editor">
</div>
</div> </div></div><style>
	.hsform-cp {
		max-width: 640px;
		width: 100%;
		background-color: #00B4F0;
        margin: 0 auto 30px auto !important;
        clear: both !important;
        box-shadow: 0 10px 25px rgba(0,0,0,0.5);
        border-radius: 4px;
		padding: 20px;
		box-sizing: border-box;
	}
	.hsform-cp .form-header {
		margin:20px 0;
		clear: both;
	}
	.hsform-cp .form-header .form-logo {
		height: 120px;
		margin: 0 20px 0 0;
		float: left;
		display: block;
	}
	.hsform-cp .form-header .form-text {
		text-align: left;
		font-family: "Palatino Linotype", "Book Antiqua", Palatino, serif;
		font-size: 24px;
		font-weight: 400;
		line-height: 28px;
		color: #FFFFFF;		
	}
	.hsform-cp .form-body input.hs-input {
		padding: 15px 12px 15px 12px;
		margin: 0 auto 10px auto;
		width: 100%;
		box-sizing: border-box;
		height: auto;
		font-size: 16px;
		font-weight: 400;
		line-height: 21px;
		color: #000000;
		border: 1px solid #d4d3d3;
		background: #f6f6f6;
		box-shadow: 0 1px 0 rgba(255,255,255,0.67),inset 0 1px 3px rgba(5,5,5,0.13);
		border-radius: 3px;
	}
	.hsform-cp .form-body .hs-error-msgs label  {
		color: #B00000;
		font-weight: 700;
		font-size: 16px;		
	}
	.hsform-cp .form-body label {
		color: #FFFFFF;
		font-size: 16px;		
	}
	.hsform-cp .form-body .hs-button {
		font-family: Arial, Helvetica, sans-serif;
	    font-weight: 700;
	    font-size: 22px;
	    line-height: 27px;
	    background-color: #FFFF00;
    	text-align: center;
    	border: 1pt solid #C0C0C0;
	    box-sizing: border-box;
    	color: #000000;
    	text-shadow: 0 0.1em 0.3em rgba(0,0,0,0.3);
    	cursor: pointer;
	    border-radius: 3px;
    	width: 100%;
    	padding: 15px 0 15px 0;
    	margin: 10px auto 10px auto;
	    height: auto;
	}
	.hsform-cp .form-body .submitted-message {
		font-size: 18px;
		color: #ffffff;
		height: auto;
		overflow: hidden;
		padding-top: 15px;
		text-align: center;
	}
</style> </div>
<div class="span4 column_container td-post-sidebar" role="complementary" itemscope="itemscope" itemtype="https://schema.org/WPSideBar">
<div class="td-a-rec td-a-rec-id-custom_ad_1 ">
<div id='div-gpt-ad-1428502564272-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1428502564272-0'); });
</script>
</div></div><aside class="widget widget_text"><div class="block-title"><span>Follow Us</span></div> <div class="textwidget"><center><div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.4";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
<div class="fb-page" data-href="https://www.facebook.com/churchpopsite" data-width="300" data-height="500" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true" data-show-posts="false"><div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/churchpopsite"><a href="https://www.facebook.com/churchpopsite">Church POP</a></blockquote></div></div>
<br><br>
<a href="https://twitter.com/church_pop" class="twitter-follow-button" data-show-count="true" data-size="large">Follow @church_pop</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script></center>
<br>
<div id="sb_instagram" class="sbi sbi_mob_col_auto sbi_col_3" style="width:100%; padding-bottom: 10px; " data-id="3611793444" data-num="9" data-res="auto" data-cols="3" data-options='{&quot;sortby&quot;: &quot;none&quot;, &quot;showbio&quot;: &quot;true&quot;,&quot;feedID&quot;: &quot;3611793444&quot;, &quot;headercolor&quot;: &quot;000000&quot;, &quot;imagepadding&quot;: &quot;5&quot;,&quot;mid&quot;: &quot;M2E4MWE5Zg==&quot;, &quot;disablecache&quot;: &quot;false&quot;, &quot;sbiCacheExists&quot;: &quot;true&quot;,&quot;callback&quot;: &quot;MDMyMmI5ZmRjODU4.NDc0Njk1OTI2YzA1NzBmMmQ1NmU=&quot;, &quot;sbiHeaderCache&quot;: &quot;true&quot;}'><div class="sb_instagram_header" style="padding: 10px; padding-bottom: 0;"></div><div id="sbi_images" style="padding: 5px;"><div class="sbi_loader"></div></div><div id="sbi_load" class="sbi_hidden"><a class="sbi_load_btn" href="javascript:void(0);" style="display: none; "><span class="sbi_btn_text">Load More...</span><span class="sbi_loader sbi_hidden"></span></a><span class="sbi_follow_btn"><a href="https://www.instagram.com/" style="" target="_blank" rel="noopener"><i class="fa fab fa-instagram"></i>Follow on Instagram</a></span></div></div>
<br>
<center><a href="https://www.facebook.com/churchpopsite/"><img src="https://churchpop.com/wp-content/uploads/2017/11/live-schedule-6pm-et-rounded.png" alt="liveschedule" width="300" height="300"></a></center></div>
</aside><div class="td-a-rec td-a-rec-id-custom_ad_2 ">
<div id='div-gpt-ad-1428502564272-1'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1428502564272-1'); });
</script>
</div></div> </div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="td-footer-wrap">
<div class="container">
<div class="row">
<div class="span12">
<div class="td-grid-wrap">
<div class="container-fluid">
<div class="wpb_row row-fluid ">
<div class="span4 wpb_column column_container">
</div>
<div class="span4 wpb_column column_container">
</div>
<div class="span4 wpb_column column_container">
</div>
 </div>
</div>
</div>
</div>
</div>
</div>
</div> 
<div class="td-sub-footer-wrap">
<div class="container ">
<div class="row">
<div class="span12">
<div class="td-grid-wrap">
<div class="container-fluid">
<div class="row-fluid ">
<div class="span4 td-sub-footer-copy">
&copy; 2017 ChurchPOP. <a href=disclaimer>Disclaimer</a> | <a href=privacy-policy>Privacy Policy</a> </div>
<div class="span8 td-sub-footer-menu">
<div class="menu-informational-container"><ul id="menu-informational" class=""><li id="menu-item-13099" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-not-mega menu-item-13099"><a href="http://es.churchpop.com">Español</a></li>
<li id="menu-item-15029" class="menu-item menu-item-type-custom menu-item-object-custom td-not-mega menu-item-15029"><a href="http://pt.churchpop.com">Português</a></li>
<li id="menu-item-22710" class="menu-item menu-item-type-custom menu-item-object-custom td-not-mega menu-item-22710"><a href="http://it.churchpop.com/">Italiano</a></li>
<li id="menu-item-73" class="menu-item menu-item-type-post_type menu-item-object-page td-not-mega menu-item-73"><a href="https://churchpop.com/about/">About</a></li>
<li id="menu-item-218" class="menu-item menu-item-type-post_type menu-item-object-page td-not-mega menu-item-218"><a href="https://churchpop.com/submissionstips/">Submissions/Tips</a></li>
<li id="menu-item-15922" class="menu-item menu-item-type-custom menu-item-object-custom td-not-mega menu-item-15922"><a href="http://ewtnadvertising.com/churchpop-com/">Advertising</a></li>
<li id="menu-item-281" class="menu-item menu-item-type-custom menu-item-object-custom td-not-mega menu-item-281"><a href="https://feeds.feedburner.com/Churchpop">RSS</a></li>
<li id="menu-item-74" class="menu-item menu-item-type-post_type menu-item-object-page td-not-mega menu-item-74"><a href="https://churchpop.com/contact/">Contact</a></li>
</ul></div> </div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>

</div>

<div class="td-sp td-scroll-up"></div>
<div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_vertical_style" style="left:0px;top:200px;background-color:transparent;"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fchurchpop.com%2F2019%2F09%2F14%2Fhouston-priest-beaten-after-gun-fails-to-fire-says-divine-intervention-saved-his-life-i-should-be-dead%2F&amp;linkname=Texas%20Priest%20Miraculously%20Survives%20Attempted%20Shooting%2C%20Suspects%E2%80%99%20Gun%20Fails%20to%20Fire%20Three%20Times%20%7C%20ChurchPOP" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fchurchpop.com%2F2019%2F09%2F14%2Fhouston-priest-beaten-after-gun-fails-to-fire-says-divine-intervention-saved-his-life-i-should-be-dead%2F&amp;linkname=Texas%20Priest%20Miraculously%20Survives%20Attempted%20Shooting%2C%20Suspects%E2%80%99%20Gun%20Fails%20to%20Fire%20Three%20Times%20%7C%20ChurchPOP" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_whatsapp" href="https://www.addtoany.com/add_to/whatsapp?linkurl=https%3A%2F%2Fchurchpop.com%2F2019%2F09%2F14%2Fhouston-priest-beaten-after-gun-fails-to-fire-says-divine-intervention-saved-his-life-i-should-be-dead%2F&amp;linkname=Texas%20Priest%20Miraculously%20Survives%20Attempted%20Shooting%2C%20Suspects%E2%80%99%20Gun%20Fails%20to%20Fire%20Three%20Times%20%7C%20ChurchPOP" title="WhatsApp" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fchurchpop.com%2F2019%2F09%2F14%2Fhouston-priest-beaten-after-gun-fails-to-fire-says-divine-intervention-saved-his-life-i-should-be-dead%2F&amp;linkname=Texas%20Priest%20Miraculously%20Survives%20Attempted%20Shooting%2C%20Suspects%E2%80%99%20Gun%20Fails%20to%20Fire%20Three%20Times%20%7C%20ChurchPOP" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_print" href="https://www.addtoany.com/add_to/print?linkurl=https%3A%2F%2Fchurchpop.com%2F2019%2F09%2F14%2Fhouston-priest-beaten-after-gun-fails-to-fire-says-divine-intervention-saved-his-life-i-should-be-dead%2F&amp;linkname=Texas%20Priest%20Miraculously%20Survives%20Attempted%20Shooting%2C%20Suspects%E2%80%99%20Gun%20Fails%20to%20Fire%20Three%20Times%20%7C%20ChurchPOP" title="Print" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div><div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style" style="bottom:0px;right:0px;background-color:transparent;"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fchurchpop.com%2F2019%2F09%2F14%2Fhouston-priest-beaten-after-gun-fails-to-fire-says-divine-intervention-saved-his-life-i-should-be-dead%2F&amp;linkname=Texas%20Priest%20Miraculously%20Survives%20Attempted%20Shooting%2C%20Suspects%E2%80%99%20Gun%20Fails%20to%20Fire%20Three%20Times%20%7C%20ChurchPOP" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fchurchpop.com%2F2019%2F09%2F14%2Fhouston-priest-beaten-after-gun-fails-to-fire-says-divine-intervention-saved-his-life-i-should-be-dead%2F&amp;linkname=Texas%20Priest%20Miraculously%20Survives%20Attempted%20Shooting%2C%20Suspects%E2%80%99%20Gun%20Fails%20to%20Fire%20Three%20Times%20%7C%20ChurchPOP" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_whatsapp" href="https://www.addtoany.com/add_to/whatsapp?linkurl=https%3A%2F%2Fchurchpop.com%2F2019%2F09%2F14%2Fhouston-priest-beaten-after-gun-fails-to-fire-says-divine-intervention-saved-his-life-i-should-be-dead%2F&amp;linkname=Texas%20Priest%20Miraculously%20Survives%20Attempted%20Shooting%2C%20Suspects%E2%80%99%20Gun%20Fails%20to%20Fire%20Three%20Times%20%7C%20ChurchPOP" title="WhatsApp" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fchurchpop.com%2F2019%2F09%2F14%2Fhouston-priest-beaten-after-gun-fails-to-fire-says-divine-intervention-saved-his-life-i-should-be-dead%2F&amp;linkname=Texas%20Priest%20Miraculously%20Survives%20Attempted%20Shooting%2C%20Suspects%E2%80%99%20Gun%20Fails%20to%20Fire%20Three%20Times%20%7C%20ChurchPOP" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_print" href="https://www.addtoany.com/add_to/print?linkurl=https%3A%2F%2Fchurchpop.com%2F2019%2F09%2F14%2Fhouston-priest-beaten-after-gun-fails-to-fire-says-divine-intervention-saved-his-life-i-should-be-dead%2F&amp;linkname=Texas%20Priest%20Miraculously%20Survives%20Attempted%20Shooting%2C%20Suspects%E2%80%99%20Gun%20Fails%20to%20Fire%20Three%20Times%20%7C%20ChurchPOP" title="Print" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div>
<script type="text/javascript">
var sbiajaxurl = "https://churchpop.com/wp-admin/admin-ajax.php";
</script>
<style type="text/css" id="hustle-module-styles"> .module_id_1 .hustle-modal .hustle-modal-image{ background-color: #165e80; } .module_id_1 .hustle-modal .hustle-modal-image{ background-color: #165e80; } .module_id_1 .hustle-modal .hustle-modal-body{ background-color: #176387; } .module_id_1 .hustle-modal .hustle-modal-title{ color: #fdfdfd; } .module_id_1 .hustle-modal .hustle-modal-subtitle{ color: #fdfdfd; } .module_id_1 .hustle-modal .hustle-modal-success{ background-color: #176387; } .module_id_1 .hustle-modal .hustle-modal-article, .hustle-modal .hustle-gdpr-content{ color: #adb5b7; } .module_id_1 .hustle-modal .hustle-modal-message blockquote{ border-left-color: #78b5d1; } .module_id_1 .hustle-modal article a:not(.hustle-modal-cta){ color: #78b5d1; } .module_id_1 .hustle-modal article a:not(.hustle-modal-cta):hover { color: #4d95b6; } .module_id_1 .hustle-modal footer{ background-color: #78b5d1; } .module_id_1 .hustle-modal .hustle-modal-optin_field input{
				background-color: #fdfdfd;
				color: #363b3f;
			} .module_id_1 .hustle-modal .hustle-modal-optin_field input:hover {
				background-color: #fdfdfd;
				color: #363b3f;
			} .module_id_1 .hustle-modal-optin_field label .hustle-modal-optin_icon .hustle-icon path{ fill: #adb5b7; } .module_id_1 .hustle-modal-optin_form .hustle-modal-optin_field label .hustle-modal-optin_placeholder{ color: #adb5b7; } .module_id_1 .hustle-modal form .hustle-modal-optin_button button{ color: #fdfdfd; background-color: #4d95b6; } .module_id_1 .hustle-modal form .hustle-modal-optin_button button:hover { color: #fdfdfd; background-color: #176387; } .module_id_1 .hustle-modal .wpoi-submit-failure { color: #f1f1f1; background: #ea6464; } .module_id_1 .hustle-modal .hustle-modal-mc_checkbox input+label{ background-color: #fdfdfd; } .module_id_1 .hustle-modal .hustle-modal-mc_checkbox input:checked+label{ background-color: #fdfdfd; } .module_id_1 .hustle-modal .hustle-modal-optin_form .hustle-modal-mc_groups .hustle-modal-mc_option .hustle-modal-mc_checkbox input:checked+label:before{ color: #38c5b5; } .module_id_1 .hustle-modal .hustle-modal-mc_radio input+label{ background-color: #fdfdfd; } .module_id_1 .hustle-modal .hustle-modal-mc_radio input:checked+label{ background-color: #fdfdfd; } .module_id_1 .hustle-modal .hustle-modal-optin_form .hustle-modal-mc_groups .hustle-modal-mc_option .hustle-modal-mc_radio input:checked+label:before{ color: #38c5b5; } .module_id_1 .hustle-modal .hustle-modal-success .hustle-modal-success_icon .hustle-icon path{ fill: #38c5b5; } .module_id_1 .hustle-modal .hustle-modal-success .hustle-modal-success_message, .hustle-modal .hustle-modal-success .hustle-modal-success_message *{ color: #fdfdfd; } .module_id_1 .hustle-modal .hustle-modal-optin_field input{ border: 3px solid #dadada; border-radius: 5px; } .module_id_1 .hustle-modal .hustle-modal-optin_form .hustle-modal-mc_groups .hustle-modal-mc_option .hustle-modal-mc_checkbox input+label:before{ color: #fdfdfd; } .module_id_1 .hustle-modal .hustle-modal-optin_form .hustle-modal-mc_groups .hustle-modal-mc_option .hustle-modal-mc_radio input+label:before{ color: #fdfdfd; } .module_id_1 .hustle-modal .hustle-modal-optin_form .hustle-modal-mc_title label{ color: #fdfdfd; } .module_id_1 .hustle-modal .hustle-modal-optin_form .hustle-modal-mc_groups .hustle-modal-mc_option .hustle-modal-mc_label label{ color: #adb5b7; } .module_id_1 .wpmudev-modal-mask{ background-color: rgba(51,51,51,0.9); } .module_id_1 .hustle-modal .hustle-modal-close svg path{ fill: #fdfdfd; } .module_id_1 .hustle-modal .hustle-modal-close svg path:hover { fill: #fdfdfd; } .module_id_1 .hustle-modal .hustle-modal-close svg path:active { fill: #fdfdfd; } .module_id_1 .hustle-modal-image img{ object-position: center center; }</style>
<script id="wpmudev-hustle-modal-with-optin-tpl" type="text/template">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</script>
<script id="wpmudev-hustle-modal-without-optin-tpl" type="text/template">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</script>
<script id="hustle-sshare-front-tpl" type="text/template">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</script>

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PZVWWRC"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>


<style type="text/css" media="screen">
                <pre>
.home .td_block_slide_big .prevButton, .home .td_block_slide_big .nextButton {
display: none;
}
</pre>

#popup-embedded-box-sxzw-1.popupally-outer-embedded-sxzw-1 {
    width: 100%;
    background-color: #00b4f0;
    margin: 0 auto;
    clear: both;
}

#td-top-search {
    position: RELATIVE;
    float: left;
    LEFT: 20px;
}

#support-churchpop {
    position: absolute;
    right: 0;
    top: 0;
}

@media (max-width: 767px) {
    #td-top-search {
        position: absolute;
        top: -2px;
        left: 41px;
    }
}

@media (max-width: 1018px) and (min-width: 768px) {
    #td-top-search {
        left: 10px;
    }
}

@media (min-width: 1200px)
    #td-top-search {
        left: 10px;
    }
}
                </style><link rel='stylesheet' id='hstl-roboto-css' href='https://fonts.googleapis.com/css?family=Roboto+Condensed%3A300%2C300i%2C400%2C400i%2C700%2C700i%7CRoboto%3A300%2C300i%2C400%2C400i%2C500%2C500i%2C700%2C700i&#038;ver=4.9.11' type='text/css' media='all' />
<link rel='stylesheet' id='hstl-opensans-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C400i%2C700%2C700i&#038;ver=4.9.11' type='text/css' media='all' />
<link rel='stylesheet' id='hstl-source-code-pro-css' href='https://fonts.googleapis.com/css?family=Source+Code+Pro&#038;ver=4.9.11' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://churchpop.com/wp-includes/css/dashicons.min.css?ver=4.9.11' type='text/css' media='all' />
<link rel='stylesheet' id='hustle_front-css' href='https://churchpop.com/wp-content/plugins/wordpress-popup/assets/css/front.min.css?ver=3.0.7' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/churchpop.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://churchpop.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sb_instagram_js_options = {"sb_instagram_at":"","font_method":"svg"};
/* ]]> */
</script>
<script type='text/javascript' src='https://churchpop.com/wp-content/plugins/instagram-feed/js/sb-instagram.min.js?ver=1.12'></script>
<script type='text/javascript' src='https://churchpop.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script type='text/javascript'>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</script>
<script type='text/javascript' src='https://churchpop.com/wp-content/plugins/wordpress-popup/assets/js/front.min.js?ver=1.1'></script>
<script type='text/javascript' src='https://churchpop.com/wp-content/themes/Newspaper/js/td_external.js?ver=4.0.2'></script>
<script type='text/javascript' src='https://churchpop.com/wp-content/themes/Newspaper/js/full_compact/site.js?ver=4.0.2'></script>
<script type='text/javascript' src='https://churchpop.com/wp-includes/js/wp-embed.min.js?ver=4.9.11'></script>

<script>
    
</script>
<img src="https://churchpop.com/wp-content/themes/Newspaper/images/AjaxLoader.gif" style="display:none">
</body>
</html>
